技术改变世界 阅读塑造人生! - shaogx.com

This string was altered by TechBlog\Plugins\Example.; This is an example to show the potential of an offcanvas layout pattern in Bootstrap. Try some responsive-range viewport sizes to see it in action.

Eclipse ADT 11.0发布 编辑功能大幅提升

日前,谷歌发布了新版本的 Eclipse ADT 11.0.0 (下载地址),该版本主要在编辑器的改进上做了很多的工作,很多新的可视化重构操作,例如“抽取 Include”和“抽取样式”,可用来自动的抽取一些重复的布局片段和样式属性,以便重用布局、样式和主题。另外,可视化布局编辑器新增对片段的支持、调色板的配置以及提升对自定义视图的支持。同时 XML 编辑也得到了改善,包括快速修复以及代码完成等方面的增强。... 全文

Eclipse ADT 11.0 ADT Android

eclipse kepler通过link方式使用ADT插件

下载eclipse和adt插件eclipse:http://www.eclipse.org/downloads/http://mirrors.hustunique.com/eclipse/technology/epp/downloads/release/luna/SR1/eclipse-java-luna-SR1-win32.zipadt:http://developer.android.com/intl/zh-cn/sdk/installing/installing-adt.htmlhttps://dl.google.com/android/ADT-23.0.4.zip... 全文

eclipse adt link

解决最新版的ADT没有NDK选项的问题

最新版的ADT不显示NDK,解决方法有两种,第一种方法在线重装一下这种方法有一个问题就是,google的东西我们经常不能访问,解决方法可以参考http://blog.csdn.net/shi_weihappy/article/details/41847997废话不多说,直接上步骤:... 全文

adt ndk

Android开发:最新版本ADT使用问题

 昨天把androidsdk和adt更新到最新版本,android sdk r22版本。  更新完后原来的项目打包后出现第三方JAR包找不到,网上搜了半天终于找到问题所在。 新版本多了一个Android Private Libraries 结构, 感觉很废, 如下图:  所有的第三方JAR包引入都被放入了Android Private Libraries中, ... 全文

Android开发 最新版本 ADT使用

Android的SDK与ADT不匹配问题

win7/xp 下面安装Android虚拟机,更新SDK后,在Eclipse preference里指向android-sdk-windows时。出现 :... 全文

Android开发 Android SDK与ADT不匹配

Android SDK更新以及ADT更新出现问题的解决办法

问题描述使用SDK Manager更新时出现问题Failed to fetch URL https://dl-ssl.google.com/android/repository/repository-6.xml, reason: Connection to https://dl-ssl.google.com refused... 全文

Android SDK ADT 解决办法

Android 4.1最终版SDK和ADT Plugin全线发布

谷歌全线放出Android 4.1 SDK全新的SDK工具版本为20.1.1, NDK的修订版本为8b,两者目前皆可使用。基于此,开发者可手握全备的工具,开发针对Jelly Bean的高质量app,这其实也表明了谷歌已了解发展自身的方向。当前,谷歌致力于7英寸 Nexus 7平板的app开发目标,这些app可自动缩放。但同时,开发者需要注意一点,这款设备不需要针对摄像头的app,因为它本身不配备后置摄像头。此外,用户可在Play Store下载适用于Nexus 7的app。以下是Android Developers网站上的相应链接:... 全文

Android 4.1 SDK ADT Plugin

Eclipse+ADT进行Android应用程序的代码混淆和签名

启动代码混淆功能在较新版本的Android tools和ADT,项目工程里面是带有proguard.cfg的代码混淆配置文件,但默认是没有启动这个配置的,需要手动地在default.properties里面添加指定这个配置文件:# Project target.target=android-3proguard.config=proguard.cfg然后按F5刷新当前项目工程,这时候Eclipse检测了文件的变动而重新编译!生成签名发布apk以下图片转自http://jojol-zhou.iteye.com/blog/7194281.Eclipse工程中右键工程,弹出选项中选择 android工具-生成签名应用包:2.选择需要打包的android项目工程(注:这里会自动选择当前的Project的):3.如果已有私钥文件,选择私钥文件 输入密码,如果没有私钥文件见 第6和7步创建私钥文件:4.输入私钥别名和密码:5.选择APK存储的位置,并完成设置 开始生成:6.没有私钥文件的情况,创建私钥文件(注:这里私钥文件的Location位置最好自己选择一个新位置,便于牢记,而且最好把这个私钥文件备份到其他地方去以免丢失,因为应用程序的更新需要同一私钥文件):7.输入私钥文件所需信息,并创建(注:这里的密码是用于Key的别名的,和上面的KeyStore文件的不同,这点可以看步骤3和4。另外下面的名字,开发者资料等是不需要全部填写的,dialog会有提示的):这时候生成的apk,我发现是比debug版本的要小!如果你发现没有变小的话,请确认项目工程是重新编译的!但代码混淆的效果一般般,基本上还是可以看到原来的语句!... 全文

Eclipse 签名 ADT 代码混淆 Android

Android实战技巧之九:最新Android开发环境(Eclipse+ADT+Android 5.0)

一、一切由运行时错误引起dalvikvm Could not find class '引用包.类', referenced from method... 其实在编译时也会见到如下错误:       [dx]        [dx] trouble processing:       [dx] bad class file magic (cafebabe) or version (0033.0000)       [dx] ...while parsing com/novell/sasl/client/DigestChallenge.class       [dx] ...while processing com/novell/sasl/client/DigestChallenge.class二、尝试1.使用JDK7有推荐使用JDK7来解决类似问题的帖子,可是我照做并没有解决问题。2.升级build-tools先来说说我的开发环境吧。那是在2013年末配置的环境,ADT大版本号是22,tools大版本号也是22,Plantform-tools已经是最新的21,build-tools是18.1.1。经过同事的实践,问题应该归咎于build-tools版本低的缘故。三、最新开发环境的搭建(Eclipse & ADT&SDK) 1.各tools的升级这里我们要重新配置一下代理,去neusoft.edu.cn镜像网站中下载最新的工具和SDK。启动 Android SDK Manager(命令行中直接输入android),Tools--->Options...,弹出Android SDK Manager - Settings窗口;在HTTP Proxy Server和HTTP Proxy Port输入框内填入mirror.neusoft.edu.cn(注意没有http等前缀)和80,并且选中Force https://... sources to be fetched using http://...复选框。 再选择Packages--->Reload。此时会发现我们顺利的取到Packages了,那么我们尽情下载吧。除了最新的Android 5.0.1还没有提供,其他的一应俱全了。... 全文

android adt sdk Android 5.0

Android开发环境构建

1.adt-bundle-windows-x86-MAT(1)Eclipse:D:Android\adt-bundle-windows-x86-MAT\eclipse(免安装)(2)Android SDK:D:Android \adt-bundle-windows-x86-MAT\sdk 2.jdk1.7.0_45(1)下载路径:Java SE Development Kit 7 Downloads... 全文

android eclipse jdk adt adb

Android开发环境安装

在开始Android开发之旅启动之前,首先要搭建环境 。打包下载开发环境所需软件 1、jdk安装 安装完成之后,可以在检查JDK是否安装成功。打开cmd窗口,输入java –version 查看JDK的版本信息。 在环境变量里设置PATH变量的值,添加JDK的bin目录的路径 2、Eclipse安装 下载解压之后即可使用。... 全文

android开发 sdk jdk eclipse adt

Android中ADT插件的安装

DT是用于开发Android的Eclipse插件,ADT想要在Eclipse上正常使用的关键是它们的版本要兼容。因此推荐在线安装ADT插件,它会根据Eclipse版本自动找到能够适应的版本的。 1.在线安装ADT插件启动Eclipse,如果是Eclipse3.5或Eclipse3.6选择“Help”>“Install New Software...”,如果Eclipse3.4及以下版本菜单是“Help”>“Software Updates...”准备安装插件。打开的对话框Eclipse版本不同对话框也是不同的,Eclipse3.5或Eclipse3.6开的对话框如图2-1所示。 ... 全文

android eclipse eclipse插件 archive tools

Android开发环境搭建(Eclipse+ADT)

前些时间由于电脑一直有问题,而且比较慢,所以重装电脑了,操作系统由原来的win 7 64位转到32位了,所以环境也只好重新搭建了。但是搭建完成后发现环境不能用了以前那样配置可以的啊!但是后来不知道为什么就是不行了。在Eclipse中创建一个新的模拟器(AVD)总是不能成功创建,点击创建后电脑没有反应。最初还以为是电脑卡了,等了半天没有反应。后来发现就是在Eclipse下无法创建。但是在开始菜单启动,就可以创建。新环境的大bug!找了好久都没有一个很好的解决方法。后来没办法了再次重新配置环境。查找官网的教程搭建环境,搭建成功了。原来是我搭建环境的顺序不对。预备软件:... 全文

android eclipse 开发环境搭建

关于android环境搭建时sdk和adt下载慢的解决方法

在下载sdk或adt插件时有时可能无法下载或者慢,因为各种我们知道的原因。我们可以通过修改hosts文件来解决。在ubuntu中,输入下面的命令:sudo gedit /etc/hosts然后在里面加入203.208.46.146 dl.google.com 203.208.46.146 dl-ssl.google.com 保存,然后重新下载,很多情况下可以解决慢的问题。... 全文

android ubuntu

在myeclipse 9.1 中安装 ADT

1 安装好你的myeclipse 9.1;2 下载ADT.zip,并解压到指定目录,待用;3 下载好你的 android-sdk-windows,将解压到确定目录,待用;4 下载这个资源 http://download.csdn.net/detail/miw__/4328208,并按提示操作。安装完成。如此这般后,开发java,web,android工程就再也不用若干个 eclipse中来回切换了。... 全文

myeclipse eclipse android java web

Android学习路线(二)创建Android项目

一个Android项目包含了Android app代码在内的所有文件。Android SDK工具提供默认的项目目录和文件让创建一个项目变得很简单。 这篇课程会向大家展示,如何通过Eclipse(包含ADT插件)或者通过在命令行使用SDK工具来创建一个新项目。... 全文

Android application adt eclipse sdk

MAC OS X10.10上Android开发环境搭建

由于Google官方已经不提供Adt-Bundle下载了,主推AndroidStudio。可以从这个链接下载http://www.androiddevtools.cn。上面不光有adt-bundle,还有最新的AndroidStudio。由于对OS X还不是很熟悉,本次采用adt-bundle安装。一,下载JDK下载方式有两种,其一是从链接http://www.androiddevtools.cn处下载,选择Mac OSX的1.8u5版本即可。截图如下:... 全文

mac os x adt jdk

ADT 无法关联libs jar包的源代码问题的解决

在Eclipse中开发Android 程序,使用ADT版本如下:Android Developer ToolsBuild: v22.0.5-757759... 全文

XMPP IM Openfire Smack

1 2